Slow connection to github.com
Incident Report for buddybuild
Resolved
Build queues cleared and clone times are stable. We'll continue to monitor, but close this incident.
Posted 5 months ago. Sep 22, 2017 - 23:31 UTC
Monitoring
With the help of the Github infra team (thanks!) we have reclaimed our git-clone performance from github.com. We will continue to monitor for regressions, and will stay in contact with the Github team. We expect the build queue to be clear shortly, and for overall build times to improve.

We've improved our monitoring for these kinds of situations, and will work with the Github team in an effort to resolve these issues more quickly in future.

It's been a long day for the buddybuild infra team. Thanks for your patience while we resolved this issue, and have a great weekend.
Posted 5 months ago. Sep 22, 2017 - 23:05 UTC
Identified
We've identified the source of the issue, and we're working with Github to resolve.

This issue is the reason why you may see your iOS build queueing for some time. Many builds are running more slowly, due to bad git-clone times from github.com, causing the whole pipeline to run more slowly.

We apologize for the length of time since the last update. We endeavor to update these incidents more frequently, to keep you in the loop.
Posted 5 months ago. Sep 22, 2017 - 22:01 UTC
Update
We're still investigating slow clone times from github.com. We've been communicating with our infra partners and have a consistent repro that we're using to troubleshoot. We will update as soon as we have some answers.
Thanks your patience while re resolve this. We know that the disruption to your workflow can be frustrating, but please know that we're working as quickly as we can.
Posted 5 months ago. Sep 22, 2017 - 18:28 UTC
Investigating
We are observing slow "git clone" data transfer for github.com. Our team is investigating the issue and reaching out to github.com team.
Thank your for your patience and understanding.
Posted 5 months ago. Sep 22, 2017 - 17:22 UTC