Issues while communicating with the Apple Developer Portal
Incident Report for buddybuild
Resolved
This incident has been resolved.
Posted Apr 22, 2019 - 16:35 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 22, 2019 - 16:35 UTC
Monitoring
The issues with the developer portal appear to have largely resolved themselves. We will continue to watch for the issue resurfacing for 24 hours.
Posted Apr 15, 2019 - 14:44 UTC
Identified
We have determined that a change in Apple's server side endpoints seems to be responsible for the ongoing issue with connecting to the developer portal. It seems that when buddybuild makes a 2FA request on a user's behalf, the token returned to buddybuild does not work correctly. We are continuing to look for workarounds.
Posted Apr 12, 2019 - 21:45 UTC
Update
While we have narrowed down the cause of this issue somewhat, we have not yet identified the direct cause. We will continue to work towards a resolution as quickly as possible.
Posted Apr 11, 2019 - 23:21 UTC
Update
We are still working to isolate the issue with buddybuild's connection to the developer portal. We appreciate your patience.
Posted Apr 11, 2019 - 16:35 UTC
Update
We are receiving an unexpected error when our users try to enter their Two-Factor Authentication code. We are continuing to investigate this issue.
Posted Apr 10, 2019 - 22:12 UTC
Investigating
The Apple Developer Portal appears to be experiencing some issues, preventing our users from connecting their accounts or refreshing verification codes.
Posted Apr 10, 2019 - 14:57 UTC