Xcode 12.0 beta is currently unavailable
Incident Report for buddybuild
Resolved
Xcode 12 betas 2 & 3 are now available on buddybuild.
Posted Jul 27, 2020 - 17:15 UTC
Monitoring
We have implemented the fix, and Xcode 12 betas 1 & 2 should now be available on buddybuild.
Posted Jul 22, 2020 - 18:47 UTC
Identified
We have identified the problem that was preventing us from having Xcode 12.0 on buddybuild. We are working on a fix now.
Posted Jul 21, 2020 - 23:03 UTC
Update
We continue to work on the issue. We do not have any additional information at this time.
Posted Jul 03, 2020 - 16:20 UTC
Update
We are still investigating this issue. We have a good understanding of the failure mode, but have not yet identified the root cause.
Posted Jul 02, 2020 - 15:17 UTC
Update
We are continuing to investigate this issue.

The build machines are still in the pre-WWDC state, and do not have the Xcode beta installed. Thank you for your continued patience.
Posted Jun 24, 2020 - 15:22 UTC
Update
We have now completed the rollback of our build machines. Xcode 12.0 beta will no longer work, despite being selectable in the UI.

Please run your builds again, and let us know if you continue to see this issue.

In the meantime, we will continue to investigate the root cause.
Posted Jun 23, 2020 - 22:45 UTC
Update
The appearance of this issue coincides with addition of Xcode 12.0 beta to our build machines yesterday at approximately 4pm PDT. At this time, the build machines were also upgraded to macOS 10.15.5, to allow for the installation of the Xcode beta.

We are going to temporarily roll back this change, which should unblock customers for the time being. Note that once this rollback is complete, builds will fail if Xcode 12.0 beta is the selected version of Xcode.
Posted Jun 23, 2020 - 22:00 UTC
Investigating
There appears to be an issue with tests. Tests will run and pass, but then the test step will time out, failing the build.

We are investigating this now.
Posted Jun 23, 2020 - 20:55 UTC
This incident affected: Build Servers (iOS).