Uploads to App Store Connect sometimes fail
Incident Report for buddybuild
Resolved
You should now be able to upload your builds to App Store Connect.
Posted Sep 02, 2020 - 21:12 UTC
Identified
We have discovered another issue relating to the original issue; that uploads to App Store Connect sometimes fail. We have a fix in progress, and will update this issue once it has been rolled out.
Posted Sep 02, 2020 - 07:21 UTC
Investigating
This issue appears to persist when connecting with an Apple ID without 2FA.

We are working on a solution for this.

In the meantime, a workaround is to use an account with 2FA to connect your buddybuild account to the developer portal.
Posted Aug 30, 2020 - 14:53 UTC
Monitoring
We have enabled a fix for this issue. Please re-connect your accounts to the developer portal and run your builds again.
Posted Aug 27, 2020 - 22:05 UTC
Identified
We have identified where the problem with buddybuild's connection to the developer portal.

For now, the workaround of manually uploading provisioning profiles is the recommended advice.
Posted Aug 27, 2020 - 16:17 UTC
Update
We are continuing to investigate this issue.
Posted Aug 20, 2020 - 23:58 UTC
Investigating
If you're using Buddybuild's integration with the Apple Developer portal, you might be experiencing the following issues:
- Unable to enter a Two-Factor Authentication code
- Build failing after "Connecting to Apple Developer Portal"

We are currently investigating. As a workaround, disconnect your Apple Developer account from buddybuild and manually upload provisioning profiles.
Posted Aug 20, 2020 - 23:57 UTC
This incident affected: Build Servers (iOS), Device Auto-Provisioning, and Build installation on devices.